DOCS has failed

Incident Report for Fluid Attacks

Postmortem

Postmortem

Impact

On May 15, 2026, some users visiting docs.fluidattacks.com encountered errors for approximately 15 minutes during a planned security update. Our team detected the issue and had it fully resolved within the same day.

What happened

We were rolling out a security improvement to the site when two parts of the update ran out of order. One piece finished before another critical piece was ready, leaving the site in an inconsistent state for a short window. Think of it like changing the locks on a door before the new keys have arrived the door ends up neither fully open nor properly secured.

Once we identified the root cause, we pushed a corrected version of the update that ensures both pieces always complete in the right order before anything becomes visible to users.

What we changed

We updated the deployment process so that user-facing parts of the site can only go live after the underlying security layer has been fully confirmed. A failed step now stops the whole update cleanly, with no partial changes reaching the site.

Going forward

We are applying this same safeguard to all similar updates across our infrastructure to prevent this from happening again. MISSING_TEST < INCOMPLETE_PERSPECTIVE

Posted May 15, 2026 - 23:12 GMT-05:00

Resolved

This incident has been resolved.
Posted May 14, 2026 - 17:15 GMT-05:00

Identified

An issue was found in DOCS.
Click for details: https://availability.fluidattacks.com
Posted May 14, 2026 - 16:45 GMT-05:00
This incident affected: Docs.