Blank screen when accessing SCA findings

Incident Report for Fluid Attacks

Postmortem

Impact

At least three users experienced a blank screen issue when accessing certain vulnerabilities. The issue started on UTC-5 25-10-03 23:52 and was reactively discovered 1.8 days (TTD) later by a customer who reported through our help desk [1] that it was not possible to access some Weaknesses. These weaknesses were linked to vulnerabilities reported under SCA, and every organization or group with weaknesses associated with SCA vulnerabilities was affected. No other modules in the platform were impacted. The problem was resolved in 13.4 hours (TTF), resulting in a total window of exposure of 2.3 days (WOE) [2].

Cause

A field that was previously used to display vulnerability information in the application was removed from the system’s API, but the platform’s interface was still trying to access it. This mismatch caused an error when loading certain weaknesses, which resulted in a blank screen [3].

Solution

The platform was updated to stop using the removed field and to retrieve the necessary vulnerability data from the correct source. This change ensures that all information loads properly and prevents similar display errors in the future [4].

Conclusion

In addition to discussing refactoring plans to prevent similar issues, the team agreed to implement a stricter validation process, ensuring that frontend dependencies are reviewed and adjusted before backend field removals. This will enhance communication and prevent similar disruptions in future releases. UNHANDLED_EXCEPTION < INFRASTRUCTURE_ERROR

Posted Oct 07, 2025 - 11:25 GMT-05:00

Resolved

The incident has been resolved, and findings now load and display correctly.
Posted Oct 06, 2025 - 10:22 GMT-05:00

Identified

It has been observed that when accessing SCA findings, the platform displays a blank screen.
Posted Oct 06, 2025 - 09:11 GMT-05:00
This incident affected: Platform.