Issues cloning repositories via Egress IP and ZTNA
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of groups experienced issues cloning repositories via Egress IP and ZTNA. The issue started on UTC-5 24-10-07 15:34 and was proactively discovered 1.2 hours (TTD) later by one of our engagement managers who reported through our help desk [1] that they encountered an error stating: Could not find the repository or resolve the host. The problem was resolved in 2.9 days (TTF), resulting in a total impact of 3 days (TTR) [2].

Cause

Cloudflare Warp was installed with different versions at the container and host levels. When Cloudflare updated Warp, the version mismatch caused an incompatibility, leading to issues during repository cloning.

Solution

Cloudflare Warp was updated at the container level using an override to fix a more recent version. Additionally, adjustments were made to the cloning logic to accommodate the changes introduced in this version [3].

Conclusion

The issue stemmed from needing the dependency in two environments with different installation methods, leading to a version mismatch. We´re working on a solution to ensure both environments always use identical versions to prevent future disparities. THIRD_PARTY_CHANGE < INCOMPLETE_PERSPECTIVE

Posted Oct 11, 2024 - 10:18 GMT-05:00

Resolved
The incident has been resolved, and repositories are now cloning successfully using Egress IP and ZTNA.
Posted Oct 10, 2024 - 16:49 GMT-05:00
Identified
Issues have been identified when cloning repositories using Egress IP and Zero Trust Network (ZTNA).
Posted Oct 08, 2024 - 09:26 GMT-05:00
This incident affected: Cloning.