Issues displaying group members
Incident Report for Fluid Attacks
Postmortem

Impact

At least two groups experienced issues when listing registered members. The issue started on UTC-5 24-10-08 10:35 and was discovered 1.2 hours (TTD) later by a client who reported it through our help desk [1], indicating that accessing the Members tab resulted in the error message `There is an error :(.` The problem was resolved in 5.5 hours (TTF) resulting in a total impact of 6.7 hours (TTR) [2].

Cause

The Members section failed to render because a required field in a user's database record was manually deleted. This caused an exception when retrieving group members, preventing the view from loading properly.

Solution

The database was manually corrected to address the data inconsistency and ensure it complied with the required schema.

Conclusion

Developers need to take full responsibility when making critical changes. They must thoroughly understand the modifications and their potential impact on system functionality to ensure everything operates smoothly. DATA_QUALITY < INCOMPLETE_PERSPECTIVE

Posted Oct 09, 2024 - 15:14 GMT-05:00

Resolved
The incident has been resolved, and now group members are being listed correctly.
Posted Oct 08, 2024 - 17:21 GMT-05:00
Identified
Issues have been identified where members are not being listed correctly in some groups.
Posted Oct 08, 2024 - 12:08 GMT-05:00
This incident affected: Platform.