Free trial validation blocking group access
Incident Report for Fluid Attacks
Postmortem

Impact

At least one user experienced problems accessing the platform. The issue was discovered by a client who reported through our help desk [1] that they were being redirected to the free trial creation interface instead of accessing their designated groups. The problem was resolved in 1.3 days (TTF) [2].

Cause

When a user is on a free trial, the system assumes they can access only one group. Consequently, the system validates only one group to determine if it has associated roots before proceeding to the "choose repositories" section for auto-enrollment. In this case, the selected group for validation happened to be the one without roots, causing the issue.

Solution

The team implemented a policy to automatically set the free trial status to completed=True when a user with an active free trial (completed=False) accepts an invitation to a group or organization that does not have an active free trial. This change ensures that the trial status is correctly updated, reflecting the assumption that the user is now associated with a different group or organization and thus concluding their free trial [3].

Conclusion

Our system currently does not allow free trial users to access multiple groups. However, if a user starts a free trial by mistake and accepts invitations to groups or organizations without active trials, it can cause redirection issues. To prevent this, we will automatically terminate the free trial when a user accepts an invitation to a group or organization that does not have an active trial. INCOMPLETE_PERSPECTIVE

Posted Sep 11, 2024 - 16:03 GMT-05:00

Resolved
The incident has been resolved, and users can now access the platform normally.
Posted Sep 06, 2024 - 18:29 GMT-05:00
Identified
It has been detected that after a user completed the free trial, the platform incorrectly redirected them to the trial validation page, preventing further actions due to the validation triggered by the absence of roots and the previous trial status.
Posted Sep 06, 2024 - 10:30 GMT-05:00
This incident affected: Platform.