Blank screen when navigating the platform

Incident Report for Fluid Attacks

Postmortem

Impact

At least one user experienced issues while navigating the platform. The issue started on UTC-5 25-07-04 12:31 and was reactively discovered 1.9 hours (TTD) later by a client who reported through our help desk [1] that a blank screen was displayed, preventing them from interacting with the platform. The problem was resolved in 3.1 hours (TTF), resulting in a total window of exposure of 5 hours (WOE) [2].

Cause

In the Vulnerabilities section of the platform, the system requests to check whether the selected group has any unresolved events. If such events exist, the platform displays a warning message above the vulnerabilities table to let users know they must address those events first. After a recent update to this request, the system did not properly handle cases where the response contained no data. This resulted in a runtime error, displaying a blank screen to users [3].

Solution

The code was updated to properly check whether the response contained data before using it. In simple terms, the platform now ensures that information is available before use, preventing this error from happening again [4].

Conclusion

Automated end-to-end (e2e) tests have been implemented to help catch similar issues earlier in the future. UNHANDLED_EXCEPTION < INCOMPLETE_PERSPECTIVE

Posted Jul 07, 2025 - 15:46 GMT-05:00

Resolved

The incident has been resolved, and navigation within the platform now works as expected.
Posted Jul 04, 2025 - 18:40 GMT-05:00

Identified

A blank screen is displayed during navigation, interrupting normal usage.
Posted Jul 04, 2025 - 15:34 GMT-05:00
This incident affected: Platform.