Issues cloning repositories with makes
Incident Report for Fluid Attacks
Postmortem

Impact

At least two internal users encountered issues when attempting to clone repositories using Makes. The issue started on UTC-5 24-10-10 12:41 and was proactively discovered 2.8 hours (TTD) later by a staff member who reported through our help desk [1] that when running the clone command, they received an error message: root does not have repos uploaded to s3. Only internal users were affected. The problem was resolved in 1.6 hours (TTF) resulting in a total impact of 4.5 hours (TTR) [2].

Cause

The repository cloning issue arose due to a code change in one of the utility libraries. This change introduced an incompatibility that affected the cloning process, leading to failure when users attempted to clone repositories [3].

Solution

The change in the utility library was reverted [4].

Conclusion

It is planned to enhance the distribution and usage of these critical utilities by implementing version control and introducing tests. These measures aim to minimize the risk of unexpected failures due to future code updates. Tests will be implemented to ensure that any changes to these libraries are properly validated [5]. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Oct 11, 2024 - 14:40 GMT-05:00

Resolved
The incident has been resolved, and repositories can now ve cloned successfully using Makes without any issues.
Posted Oct 10, 2024 - 17:32 GMT-05:00
Identified
Difficulties have been identified when attempting to clone repositories using Makes.
Posted Oct 10, 2024 - 14:48 GMT-05:00
This incident affected: Cloning.